build 1805-wk2 causes a window to restore on every switch

Feedback regarding the public beta of Dexpot is highly appreciated in this forum.
dkarr
Lachende Köchin
Lachende Köchin
Posts: 99
Joined: 24.04.2011 07:18:24

build 1805-wk2 causes a window to restore on every switch

Postby dkarr » 13.03.2012 23:57:06

I just installed build 1805-wk2 on top of 1805 to see if it fixed some particular issue (which it did not, unfortunately), and now I'm seeing a new issue that I didn't see before.

I use SysInternal's Process Explorer, but I keep it minimized most of the time. After installing 1805-wk2, I'm finding that it often unminimizes itself on every desktop switch. It isn't happening all of the time, just a lot of the time.

I've never seen it do this before.

User avatar
Patrick
Developer
Posts: 7380
Joined: 04.03.2003 14:51:26

Re: build 1805-wk2 causes a window to restore on every switc

Postby Patrick » 14.03.2012 00:08:39

:dex:

dkarr wrote:I just installed build 1805-wk2 on top of 1805 to see if it fixed some particular issue (which it did not, unfortunately)

Meaning what exactly?

I use SysInternal's Process Explorer, but I keep it minimized most of the time. After installing 1805-wk2, I'm finding that it often unminimizes itself on every desktop switch.

I tried a couple hundred desktop switches, but couldn't get it to unmininmize. Please send in a log file.

dkarr
Lachende Köchin
Lachende Köchin
Posts: 99
Joined: 24.04.2011 07:18:24

Re: build 1805-wk2 causes a window to restore on every switc

Postby dkarr » 14.03.2012 02:37:43

The other problem I was looking at was the issue with PowerPoint ignoring all keys after a desktop switch, which I believe I was talking to you about in private email.

Here's the log file. I first truncated the file, and then waited until I saw the symptom, which only took a few seconds.
Attachments
dexpot.log
(12.06 KiB) Downloaded 98 times

User avatar
Patrick
Developer
Posts: 7380
Joined: 04.03.2003 14:51:26

Re: build 1805-wk2 causes a window to restore on every switc

Postby Patrick » 14.03.2012 16:32:57

dkarr wrote:Here's the log file. I first truncated the file, and then waited until I saw the symptom, which only took a few seconds.

Thanks. Which desktop(s) is Process Explorer on? Does it run as administrator? Does Dexpot?

Could you please go to "Dexpot Settings > General > Profiles", click the "Save as" button to create a new profile and send me the profile's .dxp file, so I can have a look at your Dexpot settings?

User avatar
Patrick
Developer
Posts: 7380
Joined: 04.03.2003 14:51:26

Re: build 1805-wk2 causes a window to restore on every switc

Postby Patrick » 14.03.2012 17:57:00

dkarr wrote:The other problem I was looking at was the issue with PowerPoint ignoring all keys after a desktop switch, which I believe I was talking to you about in private email.

The PowerPoint problem should be fixed now:

dexpot.exe
Dexpot 1.5.99 Build 1805-wk2+ppp
(1.37 MiB) Downloaded 98 times

dkarr
Lachende Köchin
Lachende Köchin
Posts: 99
Joined: 24.04.2011 07:18:24

Re: build 1805-wk2 causes a window to restore on every switc

Postby dkarr » 16.03.2012 19:26:02

Just so it's clear, I still have the problem with my Process Explorer window restoring on desktop switches.

User avatar
Patrick
Developer
Posts: 7380
Joined: 04.03.2003 14:51:26

Re: build 1805-wk2 causes a window to restore on every switc

Postby Patrick » 18.03.2012 18:26:42

Just so it's clear: Which desktop(s) is Process Explorer on? Does it run as administrator? Does Dexpot?

Could you please go to "Dexpot Settings > General > Profiles", click the "Save as" button to create a new profile and send me the profile's .dxp file, so I can have a look at your Dexpot settings?

dkarr
Lachende Köchin
Lachende Köchin
Posts: 99
Joined: 24.04.2011 07:18:24

Re: build 1805-wk2 causes a window to restore on every switc

Postby dkarr » 19.03.2012 15:04:06

Here it is.

I would point out that saving my profile forced me to restart Dexpot and my web browser.

I brought up the settings dialog on desktop 2, where my web browser was located, and when I clicked "OK" on the "Save As" dialog, it seemed to empty the desktop, including the desktop preview window. I clicked OK on the "Profile saved" dialog, and that dialog went away and was replaced with the Settings dialog again. Then, I discovered that nothing in the Settings dialog responded, including the Cancel button. It appeared to think there was still a modal dialog present. My web browser was the other window that was on desktop 2, and now it's a missing window.
Attachments
saved.dxp
(13.6 KiB) Downloaded 82 times

User avatar
Patrick
Developer
Posts: 7380
Joined: 04.03.2003 14:51:26

Re: build 1805-wk2 causes a window to restore on every switc

Postby Patrick » 19.03.2012 15:23:37

Thanks. I'm beginning to think that there's something really weird going on with your system. There's no way saving a profile somehow "empties the desktop".

dkarr wrote:Then, I discovered that nothing in the Settings dialog responded, including the Cancel button. It appeared to think there was still a modal dialog present.

There actually would have been a "Profile saved successfully" message box. So if that "got disappeared" as well, it would explain this part of the problem.

dkarr
Lachende Köchin
Lachende Köchin
Posts: 99
Joined: 24.04.2011 07:18:24

Re: build 1805-wk2 causes a window to restore on every switc

Postby dkarr » 19.03.2012 16:07:46

I imagine that new test case is repeatable, so I'll try doing that again later day and upload a log file.

dkarr
Lachende Köchin
Lachende Köchin
Posts: 99
Joined: 24.04.2011 07:18:24

Re: build 1805-wk2 causes a window to restore on every switc

Postby dkarr » 19.03.2012 19:32:29

Here's a log file after repeating this "profile save" test case.
Attachments
dexpot.log
(7.08 KiB) Downloaded 83 times


Return to “Dexpot Public Beta”

Who is online

Users browsing this forum: No registered users and 1 guest