Window catalogue and DexControl render bugs

Feedback regarding the public beta of Dexpot is highly appreciated in this forum.
Guest

Window catalogue and DexControl render bugs

Postby Guest » 17.06.2012 14:56:07

First off, let me say that I just recently discovered Dexpot and it has been EXACTLY what I've wanted on Windows, so thank you for such an unbelievably powerful and well-designed application. I do have two minor bugs to report, however:

1. The Window Catalogue (active application) option only seems to work correctly when using the old-style 1.5 non-Aero interface. When I use this option with the new 1.6 Aero interface, all I see is my desktop background. I saw an earlier thread about this but it was from over a year ago and seemed to refer to this feature not working at all, so I wanted to submit a new bug specifying that this only seems to fail now on the new interface.

2. This is a very minor bug and I came across it simply playing with DexControl (hugely impressive, by the way) and seems to be merely a render glitch. Here are the steps to reproduce:

- Open full-screen preview.
- Hold the mouse button to drag any window over to another desktop, then hold down the CTRL key to trigger the animation of a copy returning to the source desktop, then release the CTRL key, then drag the window back to its source desktop, and finally release the mouse button.
- Hold down the CTRL key BEFORE clicking the window again, then drag the same window to another desktop, then bring it back to the source desktop, then release the mouse button.
- Repeat Step 2. You'll notice that when you start dragging the window this time, even though you're copying, the window in the source desktop disappears -- and when you bring the window back to the source desktop and release the mouse button, the window disappears from the source desktop entirely. However, when you actually return to that desktop, the window is still there, so this appears to be a simple render glitch in DexControl and not an issue that causes the dragged application to close.

These are admittedly minor issues in an absolutely outstanding application. Congratulations on achieving such powerful functionality while maintaining such stability and low resource consumption! :D

User avatar
Patrick
Developer
Posts: 7380
Joined: 04.03.2003 14:51:26

Re: Window catalogue and DexControl render bugs

Postby Patrick » 19.06.2012 18:38:29

:dex:

Thanks for the feedback!

1. The feature simply hasn't been implemented in DexControl yet. It will be available in the next version.

2. Fixed.

jphughan
Posts: 4
Joined: 17.06.2012 14:40:10

Re: Window catalogue and DexControl render bugs

Postby jphughan » 20.06.2012 00:29:20

Thanks, looking forward to the update. Also (let me know if this should be a new thread), I've noticed a new bug involving Firefox (running V13). I have different Firefox windows open across all 4 of my Dexpot desktops. However, I've noticed that when Firefox closes itself (such as when installing an update or if it crashes), when Firefox is relaunched, all of the window bars for the windows that it had open reappear in my taskbar (I have persistent taskbar enabled), but I can only actually get to the Firefox windows that were open on Desktop 1; the other ones don't appear anywhere. I've made sure Dexpot is always running before launching Firefox.

This is becoming a very difficult bug to live with because with no way of retrieving those "stranded" windows, I can't see what tabs were open on them or save them any other way, since Firefox only lets you save open tabs on the LAST window you close. I've already lost a few tab groups containing pages I wanted to keep open due to this. As a workaround for now I'll be pulling all of my Firefox windows onto Desktop 1 before closing it, but that won't help in the event of a crash, so a permanent fix would be much appreciated. I would even be fine with Firefox reopening all of its windows on Desktop 1, so long as all of them are available.

User avatar
Patrick
Developer
Posts: 7380
Joined: 04.03.2003 14:51:26

Re: Window catalogue and DexControl render bugs

Postby Patrick » 23.06.2012 16:32:58

jphughan wrote:I've noticed a new bug involving Firefox (running V13).

Fixed.


Return to “Dexpot Public Beta”

Who is online

Users browsing this forum: Ahrefs [Bot], Exabot [Bot] and 1 guest