Page 1 of 1

build 1805-wk2 causes a window to restore on every switch

Posted: 13.03.2012 23:57:06
by dkarr
I just installed build 1805-wk2 on top of 1805 to see if it fixed some particular issue (which it did not, unfortunately), and now I'm seeing a new issue that I didn't see before.

I use SysInternal's Process Explorer, but I keep it minimized most of the time. After installing 1805-wk2, I'm finding that it often unminimizes itself on every desktop switch. It isn't happening all of the time, just a lot of the time.

I've never seen it do this before.

Re: build 1805-wk2 causes a window to restore on every switc

Posted: 14.03.2012 00:08:39
by Patrick
:dex:

dkarr wrote:I just installed build 1805-wk2 on top of 1805 to see if it fixed some particular issue (which it did not, unfortunately)

Meaning what exactly?

I use SysInternal's Process Explorer, but I keep it minimized most of the time. After installing 1805-wk2, I'm finding that it often unminimizes itself on every desktop switch.

I tried a couple hundred desktop switches, but couldn't get it to unmininmize. Please send in a log file.

Re: build 1805-wk2 causes a window to restore on every switc

Posted: 14.03.2012 02:37:43
by dkarr
The other problem I was looking at was the issue with PowerPoint ignoring all keys after a desktop switch, which I believe I was talking to you about in private email.

Here's the log file. I first truncated the file, and then waited until I saw the symptom, which only took a few seconds.

Re: build 1805-wk2 causes a window to restore on every switc

Posted: 14.03.2012 16:32:57
by Patrick
dkarr wrote:Here's the log file. I first truncated the file, and then waited until I saw the symptom, which only took a few seconds.

Thanks. Which desktop(s) is Process Explorer on? Does it run as administrator? Does Dexpot?

Could you please go to "Dexpot Settings > General > Profiles", click the "Save as" button to create a new profile and send me the profile's .dxp file, so I can have a look at your Dexpot settings?

Re: build 1805-wk2 causes a window to restore on every switc

Posted: 14.03.2012 17:57:00
by Patrick
dkarr wrote:The other problem I was looking at was the issue with PowerPoint ignoring all keys after a desktop switch, which I believe I was talking to you about in private email.

The PowerPoint problem should be fixed now:

dexpot.exe
Dexpot 1.5.99 Build 1805-wk2+ppp
(1.37 MiB) Downloaded 99 times

Re: build 1805-wk2 causes a window to restore on every switc

Posted: 16.03.2012 19:26:02
by dkarr
Just so it's clear, I still have the problem with my Process Explorer window restoring on desktop switches.

Re: build 1805-wk2 causes a window to restore on every switc

Posted: 18.03.2012 18:26:42
by Patrick
Just so it's clear: Which desktop(s) is Process Explorer on? Does it run as administrator? Does Dexpot?

Could you please go to "Dexpot Settings > General > Profiles", click the "Save as" button to create a new profile and send me the profile's .dxp file, so I can have a look at your Dexpot settings?

Re: build 1805-wk2 causes a window to restore on every switc

Posted: 19.03.2012 15:04:06
by dkarr
Here it is.

I would point out that saving my profile forced me to restart Dexpot and my web browser.

I brought up the settings dialog on desktop 2, where my web browser was located, and when I clicked "OK" on the "Save As" dialog, it seemed to empty the desktop, including the desktop preview window. I clicked OK on the "Profile saved" dialog, and that dialog went away and was replaced with the Settings dialog again. Then, I discovered that nothing in the Settings dialog responded, including the Cancel button. It appeared to think there was still a modal dialog present. My web browser was the other window that was on desktop 2, and now it's a missing window.

Re: build 1805-wk2 causes a window to restore on every switc

Posted: 19.03.2012 15:23:37
by Patrick
Thanks. I'm beginning to think that there's something really weird going on with your system. There's no way saving a profile somehow "empties the desktop".

dkarr wrote:Then, I discovered that nothing in the Settings dialog responded, including the Cancel button. It appeared to think there was still a modal dialog present.

There actually would have been a "Profile saved successfully" message box. So if that "got disappeared" as well, it would explain this part of the problem.

Re: build 1805-wk2 causes a window to restore on every switc

Posted: 19.03.2012 16:07:46
by dkarr
I imagine that new test case is repeatable, so I'll try doing that again later day and upload a log file.

Re: build 1805-wk2 causes a window to restore on every switc

Posted: 19.03.2012 19:32:29
by dkarr
Here's a log file after repeating this "profile save" test case.