"Restoration" chrome/chromium window after opening URL

Post any technical problems or questions you have while using or configuring Dexpot.
Bug-Tracker
cra3y
Posts: 3
Joined: 05.11.2014 17:25:47

"Restoration" chrome/chromium window after opening URL

Postby cra3y » 05.11.2014 18:01:06

Hi

I will try to describe weird behaviour of dexpot and chrome/chromium, when "Keep all taskbar buttons visible" is OFF and You try to open new page from foreign URL (I mean for example: from Miranda, Notepad++ using About -> clicking on homepage url or clicking on link in email client etc).

Tested on Win7/8/8.1

You need:
1) chrome/chromium installed and configured as default browser
2) an application that will provide url links (Miranda, Adium, email client or for example notepad++)
3) dexpot 1.6.14 (latest)

How to replicate problem:
1) install and configure dexpot at least 2 desktops
2) turn "Keep all taskbar buttons visible" is OFF (in plugins)
3) install chrome/chromium and set as default browser, reboot windows
4) open chrome/chromium on desktop nr 2 and maximize it (using second from right button)
5) open notepad++ or miranda/adium (whatever) on desktop nr 1
6) click on url in ? -> About -> Homepage in notepad++ or click on link in miranda/adium (see screenshot) or from email client

notepad.png
notepad.png (19.67 KiB) Viewed 4073 times


miranda.png
miranda.png (18.38 KiB) Viewed 4071 times


7) You see that chrome is blinked for few miliseconds and disappeared (ok, chrome is on desktop nr 2, but we are in desktop nr 1), so go to desktop nr 2 and see what happened

Chrome is not maximized anymore - You have to maximize it again.

chrome.png
chrome.png (798.51 KiB) Viewed 4072 times


BUT - when You turn ON "Keep all taskbar buttons visible" and try from 4 to 6 then You see that it works as desired (link is opened on chrome, that is still maximized)

Dexpot do something, when this option is OFF - opening links from external application cause run new instance "chrome.exe" with url as parameter, and maybe Dexpot "thinks" that it should do something with new-opened app, but old instance chrome "see" that new instance is about to start and try to catch it and open new tab with new url instead run another chrome window.

I want to use "Keep all taskbar buttons visible" OFF, because I want to see on taskbar apllications from current desktop, so turning this on to fix problem is not solution for me.

Could You fix it?
Last edited by cra3y on 05.11.2014 20:01:17, edited 2 times in total.
Greetings
Krzysztof Gajda

User avatar
Patrick
Developer
Posts: 7380
Joined: 04.03.2003 14:51:26

Re: "Restoration" chrome/chromium window after opening URL

Postby Patrick » 05.11.2014 19:32:12

:dex:

Try this. Save the attached file to your Dexpot program folder and restart Dexpot.

mywechsel.ini
(35 Bytes) Downloaded 129 times

cra3y
Posts: 3
Joined: 05.11.2014 17:25:47

Re: "Restoration" chrome/chromium window after opening URL

Postby cra3y » 05.11.2014 19:41:48

Hi Patrick,

Your file fixed the problem :-) (but I not tested this fix with Chromium and Opera - both using the same engine like chrome and is expected that they are prone to the same problem described in first post)

They possibly use different window class name (different from "Chrome_WidgetWin_1")

PS: I will test and report

EDIT:
I tested and there is no problem with latest Opera (25.0.1614.68) and Firefox (Waterfox x64 flavor)
Greetings
Krzysztof Gajda

cra3y
Posts: 3
Joined: 05.11.2014 17:25:47

Re: "Restoration" chrome/chromium window after opening URL

Postby cra3y » 06.11.2014 19:54:20

Hi Patrick.

I found similar bug with notepad++

1) open notepad++ on second desktop, assign .txt files with notepad
2) open a few files, the tabs should appear in notepad
2) switch to desktop 1 and click 2x to txt file, then switch to desktop 2
3) the icon toolbar of notepad++ is collapsed/disappeared, click to another tab of notepad++ to "fix" problem


EDIT:
I fixed this bug by editing "mywechsel.ini"

Code: Select all

[Klasse]
Chrome_WidgetWin_1=move
Notepad++=move
Greetings
Krzysztof Gajda


Return to “Support”

Who is online

Users browsing this forum: No registered users and 1 guest