Page 1 of 1

Problem with Notepad++

Posted: 08.07.2014 09:53:37
by spiritRKS1910
Hello, I try run Notepad++ always in dedicated desktop (for example in 2) so I use Assign applications, add .exe file, select Desktop 2 and set switch when started. Additionally I often open new file via command "notepad++.exe + path to file" so every time when I did this Notepad++ is run again (but use only one instance, new instance replace old).

Problem is that when Notepad++ is running I don't corectly see all panel in this program (like Document switcher or Source map). This panels are wrong display after automatic switching to Desktop 2 and running Notepad++, and I must min/max Notepad++, after this everything is correct. Any advice to solve this problem?

I try use some desktop rules like max/min but they work only in one order max/min when I need min/max, but even support min/max I don't know if this operation will take to much time.

Fast test case without usign Assign applications:
1. Run Notepad++ in actual desktop (like 1) and fast switch to desktop 2 (before Notepad++ is completly running).
2. After some time back to desktop 1 and see that panels in Notepad++ are wrong display.

Re: Problem with Notepad++

Posted: 13.07.2014 12:20:16
by Patrick
:dex:

See if this helps: Save the attached file to your Dexpot installation folder and restart Dexpot.

mywechsel.ini
(27 Bytes) Downloaded 121 times

Re: Problem with Notepad++

Posted: 13.07.2014 15:24:45
by spiritRKS1910
Yes this file solve problem, when NPP is running I see one short whie flash (what is normal for this program when running) and see all panels, and when again open new file all panel still are visible. Now I see this problem exist for other programs:
http://forum.dexpot.de/viewtopic.php?f=12&t=4033
so now I will try make some research and find what exactly mywechsel.ini or wechsel.ini do.

But now I notice other problem, step to reproduce:
1. Asign NPP to desktop2 and set "When activated".
2. Run NPP in desktop1.
3. We automatically jump to NPP running in desktop2.
4. Go to other desktop.

And problem is step 4. When I go to other desktop I again automatically back to desktop2 (where NPP is running). This happen 3 time, doesn't matter if I just run NPP or open new file by "notepad++.exe + path to file" when NPP was running. After this 3 time problem disappears. Sometimes problem not exist but this happens rarely and it's hard to determine why, in most case I must 3x click.

The same is when I close some file in NPP and go to other desktop - automatically back to desktop2. Any solution?

Re: Problem with Notepad++

Posted: 13.07.2014 16:07:45
by Patrick
spiritRKS1910 wrote:so now I will try make some research and find what exactly mywechsel.ini or wechsel.ini do.

[FAQ] What is the (my)wechsel.ini file capable of?

The same is when I close some file in NPP and go to other desktop - automatically back to desktop2. Any solution?

Only one: don't use automatic switching "When activated".

Re: Problem with Notepad++

Posted: 13.07.2014 16:38:23
by spiritRKS1910
But without automatic switching "When activated" I have to do one unnecessary step - manual change desktop if we assuming that this desktop has open only NPP. I operate on some files/folders/programs in different deskops and when need open file for change I do this in source desktop but want goes to desktop2 (whwere NPP exist), what making easy, quickly and clean edit. This unnecessary 3time switching is only NPP problem or depend how Dexpot work?

Re: Problem with Notepad++

Posted: 14.07.2014 13:53:33
by Patrick
It's not how it's supposed to work, generally. Dexpot returns to desktop 2 because of an activation of Notepad++. I don't know why this activation occurs, why three times, or if it's Notepad++ itself or a plugin. We could add a timeout to the next version, so an automatic switch can't immediately bring you back to the desktop you just came from. Situations where this would be desirable are probably very rare anyway. But for the moment, you should disable automatic switching for Notepad++.