"Start with windows" & SevenDex in Windows 8 Pro 64 Bit

Post a reply


This question is a means of preventing automated form submissions by spambots.
Smilies
:D :) :( :o :shock: :? :cool: :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :wink: :!: :?: :idea: :arrow: :| :mrgreen: (wave) :ok: (nod)
View more smilies

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: "Start with windows" & SevenDex in Windows 8 Pro 64 Bit

Re: "Start with windows" & SevenDex in Windows 8 Pro 64 Bit

Post by Sebastian » 12.03.2013 10:56:44

:dex:,

danke für die Rückmeldung. Dann darfst du auch auf die 1.6.7 Build 2249 updaten. :)

Re: "Start with windows" & SevenDex in Windows 8 Pro 64 Bit

Post by suamikim » 12.03.2013 07:32:37

Hallo,

sorry für die späte Rückmeldung...

1.) Ja, mein Rechner ist in einer Domäne. Hab die Info's, die ich hier gepostet habe immer zum "depersonalisieren" etwas abgeändert und zB. die Domäne weggeschnitten usw. Dachte nicht, dass das von Relevanz ist...

2.) Mit den neuen angehängten Dateien funktioniert auf den 1. Blick alles. Dh ich kann Dexpot im Admin-Modus ausführen & die Plugins aktivieren.

Re: "Start with windows" & SevenDex in Windows 8 Pro 64 Bit

Post by Patrick » 08.03.2013 15:57:21

Ist "michaelpc\Michael" denn der korrekte Benutzername? Oder bist du evtl. in einer Domäne statt lokal angemeldet?

Ändert sich mit dieser Version was?

dexpot.exe
(1.36 MiB) Downloaded 113 times

autodex.exe
(148.5 KiB) Downloaded 112 times

Re: "Start with windows" & SevenDex in Windows 8 Pro 64 Bit

Post by suamikim » 08.03.2013 07:54:37

Patrick wrote:Wenn es nicht zu viel Mühe macht und du nochmal wie beschrieben im Task Scheduler nachsehen könntest, würde uns das sehr helfen. :wink:


Kein Problem:
task_scheduler_dexpot.png
task_scheduler_dexpot.png (103.7 KiB) Viewed 4758 times


Beim (erfolglosen) aktivieren eines Plugins erscheinen jeweils 2 neue Einträge:
- Warning (Launch condition not met, user not logged-on)
- Information (Task registration updated)

Dass ich während des aktivierens angemeldet war, brauch i wohl nicht erwähnen ;)
Ich hab mal die Details der Warning als XML-Datei angehängt. Sehe darin aber nicht sonderlich viel mehr Information als bereits im Screenshot ersichtlich...
Attachments
warning.xml
(812 Bytes) Downloaded 114 times

Re: "Start with windows" & SevenDex in Windows 8 Pro 64 Bit

Post by Patrick » 07.03.2013 15:28:08

Die Admin-Option braucht man nur, wenn man bereits andere Programme als Admin laufen hat, sonst passiert das hier.

Das Problem tritt immer mal wieder auf, aber mangels Reproduzierbarkeit konnten wir noch nicht rausfinden, was da genau schiefläuft. Wenn es nicht zu viel Mühe macht und du nochmal wie beschrieben im Task Scheduler nachsehen könntest, würde uns das sehr helfen. :wink:

Re: "Start with windows" & SevenDex in Windows 8 Pro 64 Bit

Post by suamikim » 07.03.2013 14:31:52

Aaaaah, dexpot hat in den Settings auch eine Option "Als admin ausführen". Die hab ich bisher gar nicht gesehen... Hab die ganze Zeit mit Explorer-Boardmitteln versucht zwischen Admin- & Nicht-Admin-Ausführung zu wechseln (offensichtlich ohne Erfolg)...

Und ja, im alten Profil ist "Als admin ausführen" aktiv... Macht aber nix. Wenn ichs ohne ausführe funktioniert (zumindest bisher) alles, wie gewollt.
Wozu ist die Option genau da? Benötigt für bestimmte Funktionen von Dexpot? Wenn ja, welche?

Re: "Start with windows" & SevenDex in Windows 8 Pro 64 Bit

Post by Patrick » 07.03.2013 13:41:01

Sicher, dass es nicht einfach wieder an der "Als Administrator ausführen"-Option liegt? In der Standardkonfiguration läuft Dexpot ohne Adminrechte.

Re: "Start with windows" & SevenDex in Windows 8 Pro 64 Bit

Post by suamikim » 07.03.2013 09:18:51

Problem soeben gelöst!

Nachdem ich im Task scheduler versehentlich den Task gelöscht habe, hab ich Dexpot (wiedermal) neu installiert. Dabei hab ich dann festgestellt, dass ich bisher immer nach der Neuinstallation sofort ein altes Profil geladen habe. Erst ab dem laden des alten Profiles sind die Probleme aufgetreten.

Hab diesmal einfach das Standard-Profil beibehalten und ein paar Einstellungen händisch vorgenommen und siehe da: Dexpot startet automatisch mit Windows & die Plugins funktionieren (SevenDex startet automatisch mit Dexpot, ...).

Vielen herzlichen dank für die ausgiebige Hilfe!

Re: "Start with windows" & SevenDex in Windows 8 Pro 64 Bit

Post by Patrick » 06.03.2013 22:46:21

Mach mal über "Control Panel > Administrative Tools" den Windows Task Scheduler (Aufgabenplanung) auf, aktivier rechts am Rand die Task History und versuch nochmal ein Plugin zu starten. Geh dann im Task Scheduler zum History-Tab für Task "1" im Ordner "Dexpot". Werden dort irgendwelche Fehler angezeigt oder gibt es sonstige Auffälligkeiten?

Normalerweise sollte es ungefähr so aussehen:

task_scheduler.png
task_scheduler.png (124.53 KiB) Viewed 4778 times

Re: "Start with windows" & SevenDex in Windows 8 Pro 64 Bit

Post by suamikim » 06.03.2013 14:55:13

Ok, das Logfile mit den files aus deinem Anhang sieht folgendermaßen aus:

Code: Select all

14:48:43> Starte Dexpot...
14:48:43> ElevationType 3
14:48:43> Starte Dexpot...
14:48:43> Kommandozeilenparameter: /admin Michael
14:48:43> ElevationType 2
14:48:43> Letztes geladenes Profil: mike
14:48:43> Lade Hauptmen��
14:48:43> >>> Dexpot 1.6.6 Build 2227-suamikim gestartet.
14:48:43> Windowsversion: NT 6.2.9200
14:48:43> 24 Sprachen geladen.
14:48:43> Lade Sprache f��rmTaskleiste.
14:48:43> Desktop Folder: C:\Users\xxx\Desktop
14:48:43> Speichere Profil C:\Users\xxx\AppData\Roaming\Dexpot\profile\Standard.dxp.
14:48:46> Desktop Folder: C:\Users\xxx\Desktop
14:48:46> Warte auf Dexpot64...
14:48:46> Dexpot64 gestartet.
14:48:46> ChangeWindowMessageFilter 1
14:48:46> hooxpot geladen.
14:48:46> Registriere Hotkeys.
14:48:46> Lade WechselAusnahmen aus C:\Program Files (x86)\Dexpot\wechsel.ini.
14:48:46> Dexpot64 Message Window ge��et.
14:48:46> 0 Regeln geladen, davon 0 aktiviert.
14:48:46> Regel��pr��g abgeschlossen, 0 Regeln erf��.
14:48:46> Aktualisiere Desktop.
14:48:46> Verstecke Fenster Dexpot (1051238)
14:48:46> Automatischer Neustart folgender Plugins: DexControl
14:48:46> Windowsversion: NT 6.2.9200
14:48:46> Lade Plugin DexControl.
14:48:46> Schautostarte mit Vista-Methode: C:\Program Files (x86)\Dexpot\plugins\DexControl.exe |
14:48:49> Plugin: autodex: create auto "Michael" "C:\Program Files (x86)\Dexpot\plugins\DexControl.exe"
14:48:50> Plugin: autodex: Task count: 1
14:48:50> Plugin: autodex: Task name: 1
14:48:50> Plugin: autodex: Path: C:\Program Files (x86)\Dexpot\autodex.exe
14:48:50> Plugin: autodex: Arguments: run "C:\Program Files (x86)\Dexpot\plugins\DexControl.exe"
14:48:50> Plugin: autodex: Task registered
14:48:56> Lade Sprache f��rmEinstellungen.
14:48:56> Windowsversion: NT 6.2.9200
14:48:56> Windowsversion: NT 6.2.9200
14:48:56> Lade Sprache f��rmEinstellungen.
14:48:59> Schautostarte mit Vista-Methode: C:\Program Files (x86)\Dexpot\plugins\Wallpaper Clock.exe |
14:49:02> Plugin: autodex: create auto "Michael" "C:\Program Files (x86)\Dexpot\plugins\Wallpaper Clock.exe"
14:49:02> Plugin: autodex: Task count: 1
14:49:02> Plugin: autodex: Task name: 1
14:49:02> Plugin: autodex: Path: C:\Program Files (x86)\Dexpot\autodex.exe
14:49:02> Plugin: autodex: Arguments: run "C:\Program Files (x86)\Dexpot\plugins\Wallpaper Clock.exe"
14:49:03> Plugin: autodex: Task registered
14:49:03> Schautostarte mit Vista-Methode: C:\Program Files (x86)\Dexpot\plugins\Taskbar Pager.exe |
14:49:06> Plugin: autodex: create auto "Michael" "C:\Program Files (x86)\Dexpot\plugins\Taskbar Pager.exe"
14:49:06> Plugin: autodex: Task count: 1
14:49:06> Plugin: autodex: Task name: 1
14:49:06> Plugin: autodex: Path: C:\Program Files (x86)\Dexpot\autodex.exe
14:49:06> Plugin: autodex: Arguments: run "C:\Program Files (x86)\Dexpot\plugins\Taskbar Pager.exe"
14:49:07> Plugin: autodex: Task registered
14:49:07> Schautostarte mit Vista-Methode: C:\Program Files (x86)\Dexpot\plugins\Slideshow.exe |
14:49:10> Plugin: autodex: create auto "Michael" "C:\Program Files (x86)\Dexpot\plugins\Slideshow.exe"
14:49:10> Plugin: autodex: Task count: 1
14:49:10> Plugin: autodex: Task name: 1
14:49:10> Plugin: autodex: Path: C:\Program Files (x86)\Dexpot\autodex.exe
14:49:10> Plugin: autodex: Arguments: run "C:\Program Files (x86)\Dexpot\plugins\Slideshow.exe"
14:49:11> Plugin: autodex: Task registered
14:49:11> Schautostarte mit Vista-Methode: C:\Program Files (x86)\Dexpot\plugins\SevenDex.exe |
14:49:14> Plugin: autodex: create auto "Michael" "C:\Program Files (x86)\Dexpot\plugins\SevenDex.exe"
14:49:14> Plugin: autodex: Task count: 1
14:49:14> Plugin: autodex: Task name: 1
14:49:14> Plugin: autodex: Path: C:\Program Files (x86)\Dexpot\autodex.exe
14:49:14> Plugin: autodex: Arguments: run "C:\Program Files (x86)\Dexpot\plugins\SevenDex.exe"
14:49:14> Plugin: autodex: Task registered
14:49:15> Plugin angemeldet: MouseEvents
14:49:15> Windowsversion: NT 6.2.9200
14:49:15> Windowsversion: NT 6.2.9200
14:49:16> Schautostarte mit Vista-Methode: C:\Program Files (x86)\Dexpot\plugins\Dexgrid.exe |
14:49:19> Plugin: autodex: create auto "Michael" "C:\Program Files (x86)\Dexpot\plugins\Dexgrid.exe"
14:49:19> Plugin: autodex: Task count: 1
14:49:19> Plugin: autodex: Task name: 1
14:49:19> Plugin: autodex: Path: C:\Program Files (x86)\Dexpot\autodex.exe
14:49:19> Plugin: autodex: Arguments: run "C:\Program Files (x86)\Dexpot\plugins\Dexgrid.exe"
14:49:20> Plugin: autodex: Task registered
14:49:20> Schautostarte mit Vista-Methode: C:\Program Files (x86)\Dexpot\plugins\Dexcube.exe |
14:49:23> Plugin: autodex: create auto "Michael" "C:\Program Files (x86)\Dexpot\plugins\Dexcube.exe"
14:49:23> Plugin: autodex: Task count: 1
14:49:23> Plugin: autodex: Task name: 1
14:49:23> Plugin: autodex: Path: C:\Program Files (x86)\Dexpot\autodex.exe
14:49:23> Plugin: autodex: Arguments: run "C:\Program Files (x86)\Dexpot\plugins\Dexcube.exe"
14:49:23> Plugin: autodex: Task registered
14:49:24> Schautostarte mit Vista-Methode: C:\Program Files (x86)\Dexpot\plugins\DexControl.exe |
14:49:27> Plugin: autodex: create auto "Michael" "C:\Program Files (x86)\Dexpot\plugins\DexControl.exe"
14:49:27> Plugin: autodex: Task count: 1
14:49:27> Plugin: autodex: Task name: 1
14:49:27> Plugin: autodex: Path: C:\Program Files (x86)\Dexpot\autodex.exe
14:49:27> Plugin: autodex: Arguments: run "C:\Program Files (x86)\Dexpot\plugins\DexControl.exe"
14:49:27> Plugin: autodex: Task registered
14:49:29> L��e Hotkeys.
14:49:29> Registriere Hotkeys.
14:50:02> Beende Dexpot... (1)
14:50:02> Beim Beenden noch angemeldete Plugins: MouseEvents
14:50:02> L��e Hotkeys.
14:50:02> Speichere Profil C:\Users\xxx\AppData\Roaming\Dexpot\profile\mike.dxp.
14:50:05> Sammle Fenster auf Desktop 1
14:50:05> <<< Dexpot beendet. <<<
14:50:05> frmTaskleiste entladen.


Vorgegangen bin ich folgendermaßen:
- Dexpot beendet
- Deine Dateien ins Dexpot-Verzeichnis kopiert (Originale überschrieben)
- Dexpot gestartet
- Versucht einige Plugins zu aktivieren (auch hier war MouseEvents wieder das einzige, dass ich aktivieren konnte)
- Dexpot beendet

Re: "Start with windows" & SevenDex in Windows 8 Pro 64 Bit

Post by Patrick » 06.03.2013 13:43:48

Bitte beende Dexpot, kopiere die beiden angehängten Dateien in deinen Dexpot-Installationsordner und erstelle mit dieser Version eine neues Log.

dexpot.exe
(1.36 MiB) Downloaded 142 times

autodex.exe
(148.5 KiB) Downloaded 115 times

Re: "Start with windows" & SevenDex in Windows 8 Pro 64 Bit

Post by suamikim » 06.03.2013 07:56:18

Ja, starte Dexpot momentan immer manuell und kann keine Plugins (SevenDex, ...) benutzen...

Über Hilfe wäre ich nach wie vor sehr dankbar!

Re: "Start with windows" & SevenDex in Windows 8 Pro 64 Bit

Post by Patrick » 05.03.2013 18:07:50

Besteht das Problem immer noch?

Re: "Start with windows" & SevenDex in Windows 8 Pro 64 Bit

Post by suamikim » 20.02.2013 08:20:44

Keine weiteren Ideen? Würde mich über Hilfe sehr freuen...

Danke

Re: "Start with windows" & SevenDex in Windows 8 Pro 64 Bit

Post by suamikim » 11.02.2013 17:37:09

Ok, hatte die UAC bisher deaktiviert. Daher ist beim starten bisher auch keine Sicherheitsabfrage gekommen. Wenn ich die UAC aber aktiviere, kommt die Sicherheitsabfrage wenn ich Dexpot starte. Dh dexpot startet immer mit Adminrechten.

Bei der UAC-Abfrage kann ich Dexpot die Adminrechte manuell verweigern was dazu führt, dass ich die Plugins wieder aktivieren kann. Schätze mal Dexpot braucht für den dauerhaften Betrieb die Adminrechte um zB. Profile, Einstellungen usw speichern zu können?

Ich poste hier mal das gewünschte Log-File, dass entsteht wenn ich Dexpot mit Adminrechten laufen lasse und versuche Plugins zu aktivieren (MouseEvents ist das einzige Plugin, dass sich aktivieren lässt):

Code: Select all

17:26:49> Lösche Hotkeys.
17:26:49> Registriere Hotkeys.
17:27:21> Beende Dexpot... (1)
17:27:21> Beim Beenden noch angemeldete Plugins:
17:27:21> Lösche Hotkeys.
17:27:21> Speichere Profil C:\Users\xxx\AppData\Roaming\Dexpot\profile\mike.dxp.
17:27:24> Sammle Fenster auf Desktop 1
17:27:24> <<< Dexpot beendet. <<<
17:27:24> frmTaskleiste entladen.
17:27:27> Starte Dexpot...
17:27:27> ElevationType 3
17:27:28> Starte Dexpot...
17:27:28> Kommandozeilenparameter: /admin Michael
17:27:28> ElevationType 2
17:27:28> Letztes geladenes Profil: mike
17:27:28> Lade Hauptmenü...
17:27:29> >>> Dexpot 1.6.6 Build 2227 gestartet.
17:27:29> Windowsversion: NT 6.2.9200
17:27:29> 24 Sprachen geladen.
17:27:29> Lade Sprache für frmTaskleiste.
17:27:29> Desktop Folder: C:\Users\xxx\Desktop
17:27:29> Speichere Profil C:\Users\xxx\AppData\Roaming\Dexpot\profile\Standard.dxp.
17:27:32> Desktop Folder: C:\Users\xxx\Desktop
17:27:32> Warte auf Dexpot64...
17:27:32> Dexpot64 gestartet.
17:27:32> ChangeWindowMessageFilter 1
17:27:32> hooxpot geladen.
17:27:32> Registriere Hotkeys.
17:27:32> Lade WechselAusnahmen aus C:\Program Files (x86)\Dexpot\wechsel.ini.
17:27:32> Dexpot64 Message Window geöffnet.
17:27:32> 0 Regeln geladen, davon 0 aktiviert.
17:27:32> Regelüberprüfung abgeschlossen, 0 Regeln erfüllt.
17:27:32> Aktualisiere Desktop.
17:27:32> Verstecke Fenster Dexpot (329020)
17:27:32> Automatischer Neustart folgender Plugins:
17:27:36> Lade Sprache für frmEinstellungen.
17:27:36> Windowsversion: NT 6.2.9200
17:27:36> Windowsversion: NT 6.2.9200
17:27:36> Lade Sprache für frmEinstellungen.
17:27:40> Schautostarte mit Vista-Methode: C:\Program Files (x86)\Dexpot\plugins\SevenDex.exe |
17:27:44> Plugin angemeldet: MouseEvents
17:27:44> Windowsversion: NT 6.2.9200
17:27:44> Windowsversion: NT 6.2.9200
17:27:46> Schautostarte mit Vista-Methode: C:\Program Files (x86)\Dexpot\plugins\Dexgrid.exe |
17:27:50> Schautostarte mit Vista-Methode: C:\Program Files (x86)\Dexpot\plugins\Dexcube.exe |
17:27:54> Schautostarte mit Vista-Methode: C:\Program Files (x86)\Dexpot\plugins\DexControl.exe |
17:27:58> Schautostarte mit Vista-Methode: C:\Program Files (x86)\Dexpot\plugins\SevenDex.exe |
17:28:03> Schautostarte mit Vista-Methode: C:\Program Files (x86)\Dexpot\plugins\Slideshow.exe |
17:28:07> Schautostarte mit Vista-Methode: C:\Program Files (x86)\Dexpot\plugins\Taskbar Pager.exe |
17:28:11> Schautostarte mit Vista-Methode: C:\Program Files (x86)\Dexpot\plugins\Wallpaper Clock.exe |
17:28:15> Plugin abgemeldet: MouseEvents
17:28:15> Windowsversion: NT 6.2.9200
17:28:15> Windowsversion: NT 6.2.9200
17:28:17> Lösche Hotkeys.
17:28:17> Registriere Hotkeys.


Danke

Re: "Start with windows" & SevenDex in Windows 8 Pro 64 Bit

Post by Patrick » 11.02.2013 16:16:20

Wenn beim Start keine UAC-Sicherheitsabfrage kommt, müsste es ohne Adminrechte laufen.

Bitte aktivier die Dexpot-Logdatei, starte Dexpot neu, versuch ein Paar Plugins zu aktivieren und schick mir dann das Log.

Re: "Start with windows" & SevenDex in Windows 8 Pro 64 Bit

Post by suamikim » 11.02.2013 15:32:54

Auch wenn ich dexpot manuell starte kann ich die Plugins nicht aktivieren. Egal, ob ich übers Startmenü oder direkt über den Explorer mit dexpot.exe oder dexpot64.exe starte. Keine Ahnung, ob das Programm dann als Admin läuft oder nicht. Wie kann ich das rausfinden?

Hab zum testen auch mal den Virenscanner komplett deaktiviert. Selbes problem, dh ich denke nicht, dass autodex irgendwo blockiert wird.

Noch was: Nach der installation von Dexpot und laden meines alten Profils wurde SevenDex noch korrekt gestartet. Erst seit dem 1. neustart nach installation kann ich keine Plugins mehr aktivieren.

Re: "Start with windows" & SevenDex in Windows 8 Pro 64 Bit

Post by Patrick » 11.02.2013 14:05:29

:dex:

Starte Dexpot mal manuell ohne Adminrechte. Funktionieren die Plugins dann? Wenn ja, gibt es ein Problem mit dem Programm "autodex.exe" (befindet sich im Dexpot-Programmverzeichnis). Wird der Start von Autodex evtl. durch ein Antivirus- oder sonstiges Sicherheitsprogramm blockiert?

"Start with windows" & SevenDex in Windows 8 Pro 64 Bit

Post by suamikim » 11.02.2013 09:06:02

Hallo,

seit meinem update auf Win 8 Professional (64 bit) startet Dexport nicht mehr mit Windows obwohl die "Start with windows" Option aktiviert ist.

Das selbe Problem hatte ich zuvor auch unter Win 7 konnte es aber mittels manueller Installation & Registrierung der VB6 Common Controls lösen (wie in diesem Thread beschrieben: http://dexpot.de/forum/viewtopic.php?f=12&t=2581).

Leider funktioniert diese Vorgehensweise in Win 8 bei mir nicht mehr. Die einzige Lösung, die ich bisher finden konnte, war einen eigenen Task im Windows TaskScheduler anzulegen, der Dexpot bei Login startet.

Dabei hab ich aber weiterhin folgendes Problem:
Dexport startet nun zwar automatisch beim Login, jedoch startet SevenDex nicht mit Dexport und ich kann es in den Plugin-Settings auch nicht aktivieren. Wenn ich auf die Checkbox von SevenDex klicke, erscheint für kurze Zeit das Ladesymbol des Maus-Zeigers, jedoch wird die Option nicht aktiviert (das selbe gilt übrigens auch für alle anderen Plugins, ...).

Ich wäre über jede Hilfe sehr dankbar!

Danke, mfg

mike

Top